28.3.09

Hacer Funcionar el LED indicador de actividad en un equipo con Wireless Atheros


Bueno, como ya había comentado en el post anterior, los drivers de la tarjeta Atheros no hacen funcionar el LED indicador de actividad, por lo que se complica un poco saber si la tarjeta está andando, o no; cosa que en lo personal me incomodaba un poco.

Aun así, navegando en la red, y STFW como se debe hacer, en un rincón del mundo, encontré una respuesta a mi problema (Gracias Putolinux).


En primer lugar, abres una consola, y como root, creas el siguiente fichero.

gedit /etc/sysctl.d/madwifi.conf

Y dentro del mismo pegas las siguientes lineas:

dev.wifi0.ledpin=3
dev.wifi0.softled=1

Para luego, cerrar guardando el fichero, y así reinicias tu sistema; el led debería funcionar.

4 comentarios:

GoÔnzZzaC dijo...

hey mui bueno el blog.

te pongo en mis links.

pasate por el mio.

saludos

Victor dijo...

lo hice y funciono ! :D

ahora es como un indicador de tráfico no? xD

parpadea cada vez que abro una pagina o escribo en el msn xD

saludos compa :D

tiempo sin pasar por tu blog y veo que sigues tan activo como siempre.

VittokoX de CHW

Andrés Moya dijo...

No me funcionó.
Mi equipo es un acer aspire 4520 y uso ubuntu. Estoy usando el driver libre paa el atheros.

Buen blog lo voy a indexar
Saludos

Gustavo dijo...

Confirmado. Funciona:

Mi PC
Acer Aspire 4520
Ubuntu 9.04 x86 (32 bits)
Driver WI-FI: madwifi-hal 0.10.5

tuve que hacer unos pequeños cambios

1: Ubuntu 9.04 usa el driver ath5k, el cual no funciono, hay que ponerlo en lista negra, Como?
sudo gedit /etc/init.d/blacklist.conf
y añaden blacklist ath5k

e instale el driver madwifi-hal (compilado)

2: Hay que cambiar unos cuantos nombres:
esto se hace como ROOT
En lugar de: gedit /etc/sysctl.d/madwifi.conf

Usamos: gedit /etc/sysctl.d/60-madwifi.conf

y ejecutar
invoke-rc.d procps start

(Opcional) Para que el driver inicie junto al pc:

sudo gedit /etc/modules
y añadimos: ath_pci

como me di cuenta de la "falla"

solo hay que leer esto:

dev.wifi0.ledpin=3
dev.wifi0.softled=1

el archivo que pusimos en sysctl.d apunta al dispositivo que se llama wifi0, con el modulo ath5k parece que se llama wlan0, pero pueden revisarlo escribiendo
sudo ifconfig
si aparece wifi0 trabajara

muy bueno el HOW-TO